Fehlermeldung beim Anlegen/Editieren v. Gruppen

Begonnen von , 24. Oktober 2003, 08:08:18

Vorheriges Thema - Nächstes Thema

Hey @ll,
habe mir aus dem CVS die neuesten Files von PUSER gezogen.
Beim Anlegen oder Editieren von Gruppen erhalte ich folgende Meldung:
Warning: Cannot modify header information - headers already sent by (output started at /home/www/webxxx/html/user/kopf.php:12) in /home/www/webxxx/html/user/editgroup.php on line 116[/quote]
Die Aktion mit dem Anlegen/Editieren wird aber ausgeführt.
Ich komme nicht drauf, wo der Fehler liegt.
THX für die Antworten /uploads/emoticons/icon_e_wink.gif.3167d127940f44558fbf1ccd9b6d60a9.gif\" alt=\";-)\" />

Niemand eine Idee (?) Oder bin ich der einzige, der dieses Problem hat (?)

In der editgroup.php steht:

header (\\\"Location: group.php\\\");

 
wenn ich das in

// header (\\\"Location: group.php\\\");

 
änder, ist die Fehlermeldung weg.
Liege ich damit richtig ??
Es ist übrigens auch in der Version 1.00 so.
Wäre nett, eine Antwort zu bekommen /uploads/emoticons/icon_e_wink.gif.3167d127940f44558fbf1ccd9b6d60a9.gif\" alt=\";-)\" />

Powie


Mmmh, woran kann es denn liegen, dass bei dem Anlegen/Editieren der Gruppen die Fehlermeldung erscheint ?
Habe keinen blassen Schimmer ?(?)

mahe

http://blog.mahe.at\" rel=\"external nofollow\">http://blog.mahe.at/wp-content/uploads/2007/06/88x31_1.jpg\" alt=\"88x31_1.jpg\">


Ja, diese Signatur dient zur Werbung!


Und dass ich meine Posts wiederfinde ...


Da ich mittlerweile mit der kopf.php rumprobiert habe, habe ich mir die Originaldateil nochmals aus dem CVS gezogen.
Es erscheint nun folgende Fehlermeldung beim editieren von Gruppen:
Warning: Cannot modify header information - headers already sent by (output started at /home/www/webxxx/html/user/kopf.php:10) in /home/www/webxxx/html/user/editgroup.php on line 119[/quote]
In Zeile 10 der kopf.php steht:
 

       [ Benutzer |\\\";

 
 
Das ist analog die Zeile, die vorher Zeile 12 war.
@Powie:
Übrigens scheint noch ein Fehler in Deinem Forum zu sein.
Wenn ich mir meinen Post vorher anschaue, also nicht gleich absende, erscheint die Vorschau. Danach ist aber alles weg und man muss alles nochmal schreiben.
Kleiner Fehler ???
  - Editiert von Kasten am 07.11.2003, 08:38 -


So, ich nerve schon wieder /uploads/emoticons/icon_e_wink.gif.3167d127940f44558fbf1ccd9b6d60a9.gif\" alt=\";-)\" />
Habe mir jetzt die neueste Version (freigegebene) von PUSER heruntergezogen.
Alle alte vorhandene Dateien gelöscht, neu aufgespielt, puser_createdb.php ausgeführt, klappt alles wunderbar.
Nur auch hier beim Anlegen und editieren von Gruppen folgende Fehlermeldung:
Warning: Cannot modify header information - headers already sent by (output started at /home/www/webxxx/html/user/kopf.php:2) in /home/www/web443/html/user/editgroup.php on line 119
[/quote]
Befehl wird auch ausgeführt, nur die Meldung erscheint.
Alle Dateien, bis auf die config.inc.php (Eingabe der Datenbankdaten) sind original.
So jetzt kommt Ihr, da muss doch irgendwo der Wurm drin sein. Macht mal was /uploads/emoticons/icon_e_wink.gif.3167d127940f44558fbf1ccd9b6d60a9.gif\" alt=\";-)\" />
Habt Ihr keine Probleme
Zusatz: Habe PUSER auf einen zweiten Server installiert, gleiche Fehlermeldung ;-(
 
  - Editiert von Kasten am 19.11.2003, 16:12 -

Powie

unerklärlich und nicht nachzuvollziehen.....
1. nutzt du externe kopf/fuss files
2. lad die files mal im BIN Modus hoch !!!!!

Mmmh,
zu 1. nein
zu 2. durchgeführt, keine Änderung.
Wenn ich die Gruppen über den Admin-Bereich des Forums anlege/editiere habe ich keine Fehlermeldung.
Nur wenn ich es über PUSER mache.
Die Aktion wird ja auch durchgeführt, die Meldung erscheint auch nur nach der Aktion.
Stört ja auch nicht weiter, ist nur nicht normal, oder ?

Also, wenn man die besagte Zeile 119 mit der header-Anweisung entfernt, dann klappt es.
Wozu soll die überhaupt gut sein?
In der kopf.php und der fuss.php die Pfade anpassen oder, wenn keine kopf- und fuss-Dateien benutzt werden sollen, die Anweisungen entfernen oder auskommentieren.

@mm,
Also gehe ich davon aus, dass Du die gleichen Probleme hast, oder ?
Poste einem Laien mal bitte was ich wieweit entfernen kann /uploads/emoticons/icon_e_surprised.gif.a005678239f11b45b64b526b2c82e9a1.gif\" alt=\":o\" />
Und ich dachte schon ich bin bekloppt :=(

@Kasten:
Besagte Zeile 119 mit der header-Anweisung löschen oder auskommentieren.
Wenn du ohne kopf und fuss-Dateien arbeitest, dann die Zeilen:
@include($_SERVER[\\\'DOCUMENT_ROOT\\\'].\\\"/pm/kopf.php\\\");

 in der kopf.php löschen, dito bei der fuss.php;-)

Mmm, ich bleibe bei der alten Version.
Durch die vielen User die ich habe, werden die unter PUSER auf verschiedenen, aufeinanderfolgenden Seiten angezeigt (Seite 1,2,3 usw.) nur funktionieren die Links zu den Seiten 2,3 usw. nicht.
Ich werde immer wieder auf die Seite 1 der Userliste verwiesen.
Werde es weiter über die Administration des Forums machen ;-(
Trotzdem danke mm /uploads/emoticons/icon_e_wink.gif.3167d127940f44558fbf1ccd9b6d60a9.gif\" alt=\";-)\" />

all your base are belong to us