Jump to content

Pcheck benötigt allow_url_fopen = On


Recommended Posts

Hi Powie,

aktuell wird auf Heise.de dringend dazu geraten in der php.ini den Schlüssel allow_url_fopen auf "Off" zu setzen.

Leider verwendet wohl sshcheck die Funktion fopen in Verbindung mit einer externen URL. PCheck meldet seither alle überwachten Server "NOTOK". Sobald in der php.ini der Wert auf "On" gesetzt wird sind wieder alle Server "OK".

Siehst du eine Alternative oder einen Workaround?

Link to post
Share on other sites

jo...... lass dich nicht von den Heise Geschichten verrückt machen.

Nur dadurch das die auf on steht sind noch lange keine Angriffe gegen den Server möglich.. Da gehört weitaus mehr dazu als nur die Settings in der ini.


Ich fand diesen Artikel ein wenig..... daneben und unnötig. Die Möglichkeit gibt es schon ewig...

Link to post
Share on other sites

Würde da auch ganz locker bleiben...

Ein schlechtes Script bleibt auch wenn du die Flag ausmachst ein schlechtes Script.

Letztlich ist das nur durch nachlässige Programmierung eine böse Sicherheitslücke.

blah.php?include=/etc/passwd ist nur dann gefährlich, wenn das nicht beim Programmieren beherzigt wird.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...