Jump to content
Sign in to follow this  
Guest IndoorJo

Warnung: session side-effect?

Recommended Posts

Guest

Hab mal 'ne Frage: Woher kommt die sporadische Fehlermeldung beim Aufruf einer Website und was kann man dagegen tun, wenn man nicht an die settings der php.ini rankommt?


Warning: Unknown(): Your script possibly relies on a session side-effect

which existed until PHP 4.2.3. Please be advised that the session

extension does not consider global variables as a source of data, unless

register_globals is enabled. You can disable this functionality and this

warning by setting session.bug_compat_42 or session.bug_compat_warn to

off, respectively. in Unknown on line 0

Share this post


Link to post
Share on other sites
Guest

Ich habe mal etwas recherschiert und das hier dabei gefunden. Mit anderen Worten: Da die Fehlermeldung bei Seiten auftritt, in denen pScripte impementiert sind, kann ich nichts dagegen tun!?

Share this post


Link to post
Share on other sites

ist mir mittlerweile bekannt. Ich habe aber noch nicht alle session_register Stellen gecleaned...

Share this post


Link to post
Share on other sites
Guest
Original von Powie

ist mir mittlerweile bekannt. Ich habe aber noch nicht alle session_register Stellen gecleaned...

Ah, okay. Und was kann man wie ggf. vorübergehend mit der Fehlermeldung machen (außer sie zu ignorieren :-D )?

Share this post


Link to post
Share on other sites

puffere den ganzen output, suche nach der fehlermeldung und ersetze sie durch nichts.... :ugly:

Share this post


Link to post
Share on other sites

löl.....


ich habe im Forum das session_register nirgendwo mehr in Benutzung. Es muss also noch einen anderen Grund geben.

Share this post


Link to post
Share on other sites
Guest
ich habe im Forum das session_register nirgendwo mehr in Benutzung.
Gästebuch?


BTW: Es handelt sich um das pForum 1.27 und pGb 2.10b

Share this post


Link to post
Share on other sites

Hallo,


ich kann mich Jochen nur anschließen, bin nämlich auch betroffen ;-)


Kennt jemand einen Lösungsweg?

Share this post


Link to post
Share on other sites

Ich habe das Problem mit diesem "session side-effect" immer noch nicht im Griff. Beim ersten Aufruf des Forums erscheint folgende Warnung:


Warning: Unknown(): Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0


Weiß jemand, wie ich das abstellen kann?

Share this post


Link to post
Share on other sites

Ich habe die Gründe und Ursachen herausgefunden. In meiner Version hier ist das geändert. Waren mehrere Sachen, ich kann dir momentan nicht genau sagen was da alles zu machen war.

Share this post


Link to post
Share on other sites
Das wäre für manche von uns interessant!


Ich bin einer davon und würde mich freuen, wenn Thomas uns sagen könnte, was wie in den Scripten abgeändert werden muss, um die Fehlermeldung abzustellen. :-)

Share this post


Link to post
Share on other sites

das war nicht wenig... generell war es zum Beispiel notwendig das session_register zu ersetzen, etc.

Share this post


Link to post
Share on other sites
Guest

also, die Meldung lässt sich abschießen durch eine Datei namens .htaccess, die man ins root-Verzeichnis der Website legt.


Inhalt der Datei, die per ASCII-Mode übertragen werden muss:

 

php_flag session.bug_compat_42 off
php_flag session.bug_compat_warn off

 

:-)

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...