Jump to content
powie.de Tech Forum
Sign in to follow this  
fohren

Verlinkung vom Ticker ... iframe .. Problem mit IE7

Recommended Posts

Hallo ... hat jemand vielleicht dieses Problem schon gelöst ??


Ich habe den Ticker wie gewohnt mit "iFrame" in eine html Seit eingebaut.




Seit ich den IE 7 installiert habe, verlinkt der Ticker nicht mehr auf den in der config.inc.php angegebenen Frame.


$tickerframe = "mainFrame"; //Frame auf den der Ticker linkt


Die Verlinkung wird richtig übergeben, d.h. im Quelltext ist der Link richtig aufgebaut, aber IE 7 zeigt den Artikel in einem neuen Browserfenster.


Zu 99,9 % noch ein Fehler im IE 7 aber vielleicht hat jemand eine Lösung für diese Problem ??

Share this post


Link to post
Share on other sites
Guest

Muss man das etwa im IE7 irgendwo einstellen, dass der kein neues Fenster öffnet? Mal nachgesehen?

Share this post


Link to post
Share on other sites
Guest

Unter Einstellungen - Registerbrowsen ist das einstellbar, wenn ich das richtig intepretiere...

Share this post


Link to post
Share on other sites

Hallo ... noch ein kleiner Nachtrag hierzu ... vielleicht hat ja jemand dasselbe Problem ...


Dieses Problem taucht nur auf, wenn der Ticker auf eine fremde Seite verlinkt !!

Wenn beides der iframe mit ticker.php und das Newstool selbst alles auf derselben Seite abläuft ist es kein Problem ...


Googeln mit "XHR IFrame Proxy" .... oder einfach "iframe IE7" ... da kommen viele Seiten ...


Cross Domain XHR using an IFrame Proxy ...

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×