Jump to content
powie.de Tech Forum
Sign in to follow this  
joseandres

Ich brauch ne Präsentation !!!!

Recommended Posts

Hallo Leutz,


also da ich hier immer gute Tipps bekommen habe, dachte ich in einer ruhigen Minute so bei mir. ... "Hat zwar nix mit php zu tun, aber fragen kannste ja trotzdem mal!"


Ich habe folgendes Prob. und zwar soll ich zur nächsten Versammlung die neue Homepage unserer Wehr präsentieren (wenn überhaut möglich). Jeztzt habe ich aber vor Ort keinen Internetanschluß und weiß nicht wie ich das hinbekommen soll. Alles mit Screenshots zu dokumentieren ist ziemlich mühsam.


Gibt´s nicht irgend eine Möglchkeit die Seite zumindest einigermaßen funktionsfähig vom Laptop aus zu präsentieren? Wichtig wären eigentlich nur die PHP-Scripte und der Verzeichnissschutz. Wenn die ein oder andere FrontPagekomponente auch noch funktionieren würe wäre natürlich genial.


Jo, das wär so meine kleine Sorge ....


Weiß da jemand Rat ???


Gruß Jose Andres

Share this post


Link to post
Share on other sites

Lass doch einen Webserver am Notebook laufen mit allem was du brauchst ...

(oder borg dir eine UMTS-Karte aus :L)

Share this post


Link to post
Share on other sites
Ist das recht kompliziert ?


Nein


Lad dir einfach von http://www.apachefriends.org/de/index.html Xampp runter. Das ein vorkonfigurierter Apache Server (Webserver) mit PHP, Mysql und allem was du brauchst. Einfach installieren und dann die Homepage ins htdocs Verzeichnis legen und die Datenbank anlegen usw...

- Editiert von pc_fuzzi am 01.02.2007, 14:46 -

Share this post


Link to post
Share on other sites

Also zuallerst malDanke für Eure Hilfe, ich wußte dass ich mich hier auf Euch verlassen kan :H:


Ich habe mir Xampp installiert und so wie das ausssieht auch gut hinbekommen, war nun nicht wirklich schwer.


Wo ich allerdings noch etwas hänge ist das anlegen einer MySQL Datenbank.


Erstens weiß ich nicht wie ich eine Datenbank anlege, zweitens brauche ich dann ja auch die Infos für die PHP-Scripte (Datenbankname/Hostname) Ich gehe mal davon aus, dass ich User und Passwort nicht brauche, wenn ich keine anlege?

Share this post


Link to post
Share on other sites

OK, das wird viel Denksport für mich ;-)


wenn ich im Browser http://localhost/ aufrufe, welches exacte Verzeichniss spricht Xampp dann auf meinem Rechner eigentlich an?


By the way ... wenn ich nicht falsch liege sind die gesammten News-Beiträge, Forum, FAQ´s von Powie in der Datenbank meines Providers? Ich will nämlich demnächst den Provider wechseln und bin mir jetzt garnciht sicher, wie ich eigentlich dann an diese Daten rankomme um diese bei meinem neuen Provider wieder zu haben?


Ich müßte ja eigentlich nicht nur das reine Webverzeichnis unserer Seite sichern, sondern auch die Datenbank?


WOW ... das wird ja alles richtig kompliziert *gg*

Share this post


Link to post
Share on other sites

Das wird nur dann kompliziert, wenn


a) bei deinem Hoster kein phpMyAdmin vorhanden ist

b) die Datenmenge zu groß wird

c) kein mysql_dump möglich ist


Ansonsten ist das überhaupt kein Problem.


Gruß

Jogibär

Share this post


Link to post
Share on other sites

Also phpmyAdmin hab ich gefunden, aber das einzige was er mir da anbietet ist "exportieren" ...


Dann bekomm ich ein Fenster mit dem gesammten Inhalt der DB. Hole ich mir jetzt den Inhalt einfah per Copy-Paste in den Editor und kopier das später dann in die neue DB?

Share this post


Link to post
Share on other sites

Ufff .... also jetzt hab ich es zwar geschafft die Datenbank zu exportieren, aber da gibt es ja soviele Einstellungen ... !! ..!! . .!: :gaga:


Ich habe die DB jetzt einfach mal mit allen Standardwerten exportiert und bei mir am Rechner über Xampp wieder importiert. Im Prinzip funktioniert es auch, allerdings bekomme ich egal wie ich es anstelle eine Fehlermeldung in der Tabelle "pfuser"

 

Fehler
SQL-Befehl: 

-- --------------------------------------------------------
-- 
-- Tabellenstruktur f�r Tabelle `pfuser` -- 
CREATE TABLE `pfus er ` (
`id` int( 14 ) NOT NULL AUTO_INCREMENT ,
`user name ` var char( 50 ) NOT NULL default '',
`pwd` varchar( 50 ) NOT NULL default '',
`nick name ` var char( 50 ) NOT NULL default '',
`emai l ` var char( 100 ) NOT NULL default '',
`uin` varchar( 32 ) NOT NULL default '',
`expi re ` int ( 11 ) NOT NULL default '0',
`last login ` int ( 14 ) default '0',
`logi ntime ` int ( 14 ) default '0',
`join ed ` int ( 14 ) default NULL ,
`user news ` var char( 10 ) default 'gesperrt ',
 `user faq ` var char( 10 ) default 'gesperrt ',
 `icq` varchar( 30 ) default NULL ,
`sign atur ` tex t,
`user typ ` var char( 10 ) default 'user ',
 `home page ` var char( 100 ) default NULL ,
`setz ps ` int ( 11 ) default '20', `post count ` int ( 11 ) default '0',
`grpi d ` int ( 11 ) default '0',
`info 1 ` tex t,
`info 2 ` tex t,
`info 3 ` tex t,
`usep m ` int ( 11 ) default '1',
`avat ar ` var char( 200 ) default NULL ,
`show email ` int ( 11 ) default '1',
`karm a ` int ( 11 ) default '0',
`gend er ` enu m(

'm�nnlich ','weiblich ') default 'm�nnlich ',
 `showkarma ` int(1 1
)default '0',
 `inboar d ` int(1 1

 

Da bricht er dann auch den Import ab. Weiß da wer hilfe?

Share this post


Link to post
Share on other sites

[ot]Ohoh, Umlaute im Spaltennamen. Powie, das ist nicht schön. :-D[/ot]


Exportiere die Tabllen nochmal und achte beim Import darauf, dass die Zeichencodierung richtig eingestellt ist


Gruß

Jogi

Share this post


Link to post
Share on other sites

Ich wußte, dass ich mich auf Euch verlassen kann.


Ichhabe es tatsächlich hinbekommen und kann jetzt die Homepage auf der Versammlung präsentieren und nebenbei habe ich auch noch das Problem mit der Datenbank und dem Providerwechsel gelöst.


Meinen Respect, dass ihr den Mut und die Nerven hatten einem DAU wie mir das zu erklären.


Es ist echt mal klasse einfach dumm fragen zu dürfen ohne gleich patzige antworten zu bekommen.


Danke Euch :wink:


JoseAndres


PS: Nur den FCKeditior bring ich noch nicht zum laufen. Irgendwo fehtl bestimmt noch der Hinweis auf den "Localhost" aber keine Ahnung wo.... Na das werd ich auch noch herausfinden ;-)

Share this post


Link to post
Share on other sites

*gg* Ich trau mich schon fast nicht mehr fragen ....


im Web läuft er ja wunderbar .. ich habe das gesammte Webverzeichniss ja zu mir auf den Rechner in "htdocs" kopiert und alles angepasst, aber wenn ich die Seite über "Localhost" aufrufe kann ich inzwischen die pNews aufrufen und bekomme auch die original Daten aus der DB, allerdings fehlen die Smilies aus den Posts mittels FCK Editor und auch wenn ich eine neue News schreiben wil ist der Editor nicht verfügbar.


Ich habe im Setup extra nochmal local den FCK Editor mit "ja" gespeichert. aber auch da hatte ich noch kein Glück.

Share this post


Link to post
Share on other sites

Also trotz aller Versuche schaff ich es nicht den Fehler zu finden, warum im Web der FCKeditor läuft und obwohl ich die Seite 1 zu 1 übernommen habe auf dem Rechner mit XAMPP nicht.....


Irgendwo muß wohl noch ein Verweis geändert werden, damit das Script den Editor findet. Aber WO ?

Share this post


Link to post
Share on other sites

Also erstmal DANKE für die Hilfe. Ich hätte ja nie gedacht, dass ich dieses Problem soweit gelöst bekomme.


Den FCK Editor auf dem eigenen Rechner zum laufen zu bekommen geht vermutlich nicht, aber ich denke für die Prästentation wird es auch ohne gehen. Das erklär ich dann einfach anhand eines Screenshots :-o


Jedenfalls MUCHOS THX


Gruß JoseAndres

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×