Jump to content
powie.de Tech Forum
Sign in to follow this  
lit-web

Fehler beim einloggen als Admin

Recommended Posts

Hallo ich habe jetzt die Version pshop 1.08 und alles läuft soweit gut,momentan betreibe ich das Script offline unter XAMPP.


Eine Sache ist nur nicht wie sie sein soll,wenn ich in den Admin Bereich will werde ich sofort dort hin verbunden ohne mich einloggen zu müssen und wenn ich mich aus dem Bereich ausloggen will klappt das auch nicht ich werde immer gleich in den Adminbereich verbunden ohne ein Passwort eingeben zu müssen.


Was muss ich denn ändern damit das richtig funktioniert?


Danke

Share this post


Link to post
Share on other sites

Hallo,


auch wenn das Thema nicht direkt doppelt ist, aber ich glaube, auf deine Frage habe ich dir bereits geantwortet.


Wie bereits geschrieben, würde ich mir gerne mal deine phpinfo anschauen, sowie die Version deines XAMPP's erfahren. Ich tippe auf eine Systemeinstellung die geändert werden muss. Kann es vielleicht sein, dass du ein weiteres Skript laufen hast, wo du als Admin angemeldet bist?



Grüße

Share this post


Link to post
Share on other sites

Ja das habe ich aber getrennt von dem Shop der läuft ganz sepperat und bei der Version 1.07 funktionierte das mit dem Adminbereich gut dort ging halt was anderes nicht.


Welchen Teil von der PHP Info soll ich schicken die ist so lang?

Share this post


Link to post
Share on other sites

Hallo,


ich glaube, 2 Teile könnten wichtig sein, PHP Core und session.


Sind nur Vermutungen, da ich mir zur Zeit keinen Reim darauf bilden kann, warum du einfach eingeloggt wirst. Es könnte am Cache liegen, an Cookies. Oder an was ganz anderem. Bist du bei deinem pShop 1.07 auch ausgeloggt, wenn du auf den pShop 1.08 zugreifen willst? Wenn nicht, dann liegt es daran, dass er den gleichen Cookie nutzt, obwohl es eine andere "Domain" ist. Welche Browser besitzt du und welche Version von diesem hast du ?



k00ni

Share this post


Link to post
Share on other sites

benutze FF-2.0 und den Shop 1.07 habe ich schon gar nicht mehr drauf den habe ich gelöscht und nur den 1.08 laufen,aber bei dem 1.07 lief das mit dem einloggen und ausloggen super.



PHP Core


Directive Local Value Master Value

allow_call_time_pass_reference On On

allow_url_fopen On On

always_populate_raw_post_data Off Off

arg_separator.input & &

arg_separator.output & &

asp_tags Off Off

auto_append_file no value no value

auto_prepend_file no value no value

browscap C:\Programme\xampp\php\browscap\browscap.ini C:\Programme\xampp\php\browscap\browscap.ini

default_charset no value no value

default_mimetype text/html text/html

define_syslog_variables Off Off

disable_classes no value no value

disable_functions no value no value

display_errors On On

display_startup_errors Off Off

doc_root no value no value

docref_ext no value no value

docref_root no value no value

enable_dl On On

error_append_string no value no value

error_log no value no value

error_prepend_string no value no value

error_reporting 2039 2039

expose_php On On

extension_dir C:\Programme\xampp\php\extensions\ C:\Programme\xampp\php\extensions\

file_uploads On On

gpc_order GPC GPC

highlight.bg #FFFFFF #FFFFFF

highlight.comment #FF8000 #FF8000

highlight.default #0000BB #0000BB

highlight.html #000000 #000000

highlight.keyword #007700 #007700

highlight.string #DD0000 #DD0000

html_errors On On

ignore_repeated_errors Off Off

ignore_repeated_source Off Off

ignore_user_abort Off Off

implicit_flush Off Off

include_path .;C:\Programme\xampp\php\pear\ .;C:\Programme\xampp\php\pear\

log_errors Off Off

log_errors_max_len 1024 1024

magic_quotes_gpc On On

magic_quotes_runtime Off Off

magic_quotes_sybase Off Off

max_execution_time 60 60

max_input_time 60 60

open_basedir no value no value

output_buffering no value no value

output_handler no value no value

post_max_size 16M 16M

precision 12 12

register_argc_argv On On

register_globals Off Off

report_memleaks On On

safe_mode Off Off

safe_mode_exec_dir no value no value

safe_mode_gid Off Off

safe_mode_include_dir no value no value

sendmail_from no value no value

sendmail_path no value no value

serialize_precision 100 100

short_open_tag On On

SMTP localhost localhost

smtp_port 25 25

sql.safe_mode Off Off

track_errors Off Off

unserialize_callback_func no value no value

upload_max_filesize 16M 16M

upload_tmp_dir C:\Programme\xampp\tmp C:\Programme\xampp\tmp

user_dir no value no value

variables_order EGPCS EGPCS

xmlrpc_error_number 0 0

xmlrpc_errors Off Off

y2k_compliance On On




PHP SESSION


Session Support enabled

Registered save handlers files user

Share this post


Link to post
Share on other sites

Hallo,


benutze FF-2.0 und den Shop 1.07 habe ich schon gar nicht mehr drauf den habe ich gelöscht und nur den 1.08 laufen,aber bei dem 1.07 lief das mit dem einloggen und ausloggen super.


ich wollte nicht wissen, ob das ein- und ausloggen funktionierte, sondern ob du noch im pShop 1.07 eingeloggt warst, als du auf den Adminbereich pShop 1.08 zugreifen wolltest.


Lösch mal deinen Browsercache (auf jeden Fall Cache und Cookies) und versuchs mit dem pShop 1.08 erneut.


PHP SESSION


Session Support enabled

Registered save handlers files user



Das meinte ich nicht. Sondern da muss es eine Überschrift geben, die nur session heisst.


Ich werd das Gefühl nicht los, dass es einfach daran liegt, dass er den Cookie vom pShop 1.07 auch im pShop 1.08 nutzt und du dich deshalb nicht einloggen musst.



Grüße

Share this post


Link to post
Share on other sites

Extras -> Private Daten löschen. Dann bei Cookie und Cache ein Häkchen rein. Dann auf "Private Daten jetzt löschen" klicken. Und hoffen, dass es danach funktioniert. :-D

Share this post


Link to post
Share on other sites

erstell mal eine Datei (Name egal, zB cookies.php)

schreib in die folgenden Code:


Und poste die Ausgabe mal hier.


Ich gehe davon aus dass du am Skript ausser den Variablen in der Konfig nichts geändert hast.

Share this post


Link to post
Share on other sites

Habe nichts geändert in dem Script das war schon so wo ich noch keine Änderung vorgenommen habe,auser den Datenbanknamen und was dazu gehört. Wo soll ich diese Datei rein tun?

Share this post


Link to post
Share on other sites

Ich weis nicht ob ich das richtig gemacht habe aber habe mir eine cookie.php angelegt und das was mahe hier schrieb mrein geschrieben und habe es so in der Adressleiste im Browser aufgerufen


http://localhost/pshop/cookie.php


und dann kam diese Meldung hier


array(1) { ["PHPSESSID"]=> string(32) "99e160de25e8738beededdc5368281d5" }



Was auch immer dieses aussagt

Share this post


Link to post
Share on other sites

auch ich habe ein solches ähnliches Problem


Installation verlief erfolgreich, Tabellen wurden erstellt, Rechte mit 777 vergeben (auf die Ordner)


nach dem Klick auf "Start" bei der pshop_createdb.php öffnet sich der Shop mit folgendem Fehler:


You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'l Left Join shop_test_ shop_artikel a o


was ja nicht so schlimm wäre, aber mit admin/admin kein Login in den Admin-Bereich


hülfeee


LG

Tomy

Share this post


Link to post
Share on other sites

@litta: komische Sache, ich hab mir jetzt extra nochmal den Code angesehn und kann das irgendwie nicht nachvollziehn, sorry...


@honda: das istn ganz anderes Prob, im Tabellenprefix darf kein Leerzeichen stehen!

Share this post


Link to post
Share on other sites

naja, stimmt schon, nur: ich hab ja 100% nichts verändert


er verbindet mich mit der DB, aber die DB ist und bleibt leer

Share this post


Link to post
Share on other sites
Guest
Original von honda

naja, stimmt schon, nur: ich hab ja 100% nichts verändert


er verbindet mich mit der DB, aber die DB ist und bleibt leer



Hat der Provider was verändert?

Share this post


Link to post
Share on other sites

nee, eben gar nicht!!!


ich habs ordnungsgemäß geladen, Verbindung zur DB, alles okay, er schreibt aber die Daten nicht rein in die DB und eben der Fehler mit dem Leerfeld


ob´s am Download lag??

Share this post


Link to post
Share on other sites

also, ich hab alles mit FF heruntergelden,. auf dem Server gelöscht, neu überspielt, selber fehler


http://www.thalassaemie.de/shop/


es wäre ja zu schön gewesen, aber so schnell geben wir nicht auf


oder doch ein kleines Fehlerchen in dem zip-File im download??

Share this post


Link to post
Share on other sites

also, ich hab mal noch was getestet:


SQL-Anteiel aus der pshop_createdb.php herauskopiert und direkt in die DB im phpMyAdmin eingefügt, alles geht bis auf:


$sqlbefehl= "CREATE TABLE $tab_sartikel (

id int(14) NOT NULL auto_increment,

catid int(11) DEFAULT '0' NOT NULL,

artnr varchar(20),

artbez varchar(100),

artinfo text,

arteinheit varchar(20),

artpreis double NOT NULL,

steuer double NOT NULL,

time timestamp,

status varchar(20),

gekauft int(14) DEFAULT '0',

artimg varchar(100),

PRIMARY KEY (id)

)";



Zeile 22 - 36 in der php-Datei


im phpMyAdmin steht dann folgendes:


SQL-Befehl:


$sqlbefehl = "CREATE TABLE $tab_sartikel ( id int(14) NOT NULL auto_increment, catid int(11) DEFAULT '0' NOT NULL, artnr varchar(20), artbez varchar(100), artinfo text, arteinheit varchar(20), artpreis double NOT NULL, steuer double NOT NULL, time timestamp, status varchar(20), gekauft int(14) DEFAULT '0', artimg varchar(100), PRIMARY KEY (id) )"



als ausgeführt und grün


und


MySQL meldet:


#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '$sqlbefehl= "CREATE TABLE $tab_sartikel (

id int(14) NOT NU



als Rot und Fehler


kannst du auf den ersten Blick was erkenen??

Share this post


Link to post
Share on other sites

Hallo,


du hast den PHP Code vergessen rauszunehmen. Probiere mal diese Kommandos:

 

CREATE TABLE $tab_sartikel ( id int(14) NOT NULL auto_increment, catid int(11) DEFAULT '0' NOT NULL, artnr varchar(20), artbez varchar(100), artinfo text, arteinheit varchar(20), artpreis double NOT NULL, steuer double NOT NULL, time timestamp, status varchar(20), gekauft int(14) DEFAULT '0', artimg varchar(100), PRIMARY KEY (id) )

 

CREATE TABLE $tab_sartikel (
id int(14) NOT NULL auto_increment,
catid int(11) DEFAULT '0' NOT NULL,
artnr varchar(20),
artbez varchar(100),
artinfo text,
arteinheit varchar(20),
artpreis double NOT NULL,
steuer double NOT NULL,
time timestamp,
status varchar(20),
gekauft int(14) DEFAULT '0',
artimg varchar(100),
PRIMARY KEY (id)
)

 

Wenn du weitere Kommandos setzen willst, dann entferne das "$sqlbefehl=" . Das ist PHP-Code und damit kann die Datenbank nicht soviel anfangen.


Das wird dir aber nicht dein Problem lösen. Poste mal die Zeile, wo du dein Tabellenpräfix setzt. Müsste $tabpref heißen die Variable.


[EDIT] Oh... setze mal statt dem $tab_sartikel irgendeinen Namen ein. Das ist eine Variable in PHP. Zudem musst du bei dem ersten Kommando vielleicht den Mauszeiger etwas nach rechts ziehen, da es alles auf einer Zeile liegt. [/EDIT]


k00ni

Share this post


Link to post
Share on other sites

KEIN LEERZEICHEN in $tabpref(!)

bei dir ist da eins am Schluss(!)

Das sieht man ja schon an der Fehlermeldung shop_test_ shop_artikel, da sollte aber shop_test_shop_artikel stehen.


Na, wer siehts? :wink:

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×