Jump to content
powie.de Tech Forum
Sign in to follow this  
kili

forum+Gallerie ein passwort?

Recommended Posts

wie schafft man es wie auf http://www.stereoforum.de ein forum und eine Gllerie unter einem account laufen zulassen. also dass mit mit dem Forum namen und passwort ohne neu anmelden in der Gallerie bilder hochladen kann?


danke Jakob

Share this post


Link to post
Share on other sites

Man nutzt das gleiche System für die Identifizierung der Nutzer. Beispielsweise meldet man sich im Forum an. Dann legt man einen Cookie ab, wenn der User erfolgreich eingeloggt wurde. Mit diesem Cookie kann die Galerie auch umgehen und erkennt dann, dass es sich um einen Benutzer handelt und stellt ihm die Funktionen zur Verfügung.


Dies könntest du auch relativ einfach realisieren. Nimm das pSys. Dort hast du eine Userdatenbank und kannst auch ein Forum mit einer Galerie kombinieren.



Grüße

Share this post


Link to post
Share on other sites
wie kann ich scripts wie:

http://www.phpwebgallery.net/

denn dann auch in mein Forum mit einbauen.



Auf jeden Fall nicht so einfach. Denn das sind verschiedene Benutzersysteme. Das SMF ist soweit ich weiß, eigenständig.


Du könntest dir aber Joomla laden und dann die Bridge für das SMF Forum einrichten. Dann haste schon ein Grundsystem, wo du dir dann noch eine Galeriekomponente auswählen brauchst. In wie weit und wie effektiv nun das SMF dann mit deiner Galerie zusammenarbeitet, musst du selbst schauen. Aber dies wäre mir jetzt ein guter Weg als Kompromis.



Grüße

Share this post


Link to post
Share on other sites

Google ist dein Freund. Es gibt auch ne deutsche Übersetzung. Joomlaportal.ch .. dürfte eine haben, ansonsten einfach mal suchen.



Grüße

Share this post


Link to post
Share on other sites
Guest

Du kannst aber auch die Scripte von hier nehmen, die passen immer zusammen... :wink:

Share this post


Link to post
Share on other sites

ich hätte jetzt coppermine mit mybb mit einer bridge versehen.

coppermine: http://kilkob.ki.funpic.de/copper

mybb forum: http://kilkob.ki.funpic.de/bb/Upload


die Bridge will nun folgendes wissen:

1. Vollständige Internet-Adresse Deines Forums (einschließlich http:// , z.B. http://www.yourdomain.tld/forum)

und 2.

Relativer Pfad zu Deinem Forum, von Deinem Coppermine-Verzeichnis aus gesehen (z.B. "../forum/" wenn Dein Forum unter http://www.deineseite.tld/forum/ ist und Coppermine unter http://www.deineseite.tld/gallery/)


1. is kein problem aber 2. !! Die config.php (die will er) liegt unter http://kilkob.ki.funpic.de/bb/Upload/inc/

was ist jetzt hier der relative pfad? folgendes geht nicht: :-P


../bb/Upload/

../bb/Upload/inc/

../inc/

../


danke schon im vorraus

Share this post


Link to post
Share on other sites

Versuche mal

 

../../../forum

 

Du bist im ersten Unterlevel gewesen, versuchs mal mit dem dritten.



Grüße

Share this post


Link to post
Share on other sites

Nabend,


ich hatte das falsch interpretiert, sorry. Steht da etwas da, von wo er ausgeht? Also geht er von dem Standpunkt der config-Datei aus? Wenn da nichts steht, dann poste mal deine Eintragung bei der Variable und die URL... vielleicht sieht man es da.



Grüße

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×