Jump to content
Sign in to follow this  
lit-web

Wie mache ich ein update richtig?

Recommended Posts

Ich habe ein weiteres Problem und bekomme auch Fehler meldungen.


Also das was ich in die DB eingetragen habe wird nun wie es soll auch ausgegeben das klappt sehr gut,nur wenn ich ein update machen will geht das nicht da kommen folgenede Fehlermeldungen!


Warning: mysql_query() [function.mysql-query]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Programme\xampp\htdocs\testseite\index.php on line 119


Warning: mysql_query() [function.mysql-query]: A link to the server could not be established in C:\Programme\xampp\htdocs\testseite\index.php on line 119


Ich kann mit diesen aber leider nichts anfangen,zu meiner Schmach!


Den aktuellen Code sende ich mit,vieleicht sieht jemand was ich für einen Fehler mache,denn in der syntax wüsste ich nicht wo.

 

Zurück
";
}
else
{
mysql_query("Insert Into $tab_prob (plz)
							VALUES ('$plz')")or die (mysql_error());
header("Location: index.php");
}
}
?>



" name="schicken" method="post">

Name:
















Zurück
";
}
else
{
mysql_query("update $tab_prob set 
			plz='$prob_plz'
")or die (mysql_error());

}
}
?>


" name="updaten" method="post">

Name:
">


















".$prob_plz."


";
}
?>

Share this post


Link to post
Share on other sites

So ich habe das jetzt alles mal ein bisschen sortiert und in extra dateien gelegt. Jetzt bekomme ich keine Fehlermelddungen mehr aber das Update wird nicht gemacht. Hier mal der reine Update Code!

 

Zurück
";
}
else
{
mysql_query("update $tab_prob set 
			plz='$prob_plz'
")or die (mysql_error());
header("Location: index.php");
}
}
?>


" name="updaten" method="post">

Name:
">














Share this post


Link to post
Share on other sites

Auch ein echo mysql_error liefert nichts? Wenn nicht, dann gib mal bitte den kompletten SQL-Query aus, also den String, den du an den Server sendest und poste ihn mal hier.

Share this post


Link to post
Share on other sites

So also auch das habe ich hin bekommen. Nur habe ich jetzt auch ein anderes Problem. Wie kann ich das ID speziell in der Tabelle machen,also wenn ich den Link bearbeiten anklicke das dann auch nur der bestimmte nach ID Eintrag erscheint zum editieren?

 

Löschen
Bearbeiten

 

Der Link zum löschen funktioniert einwandrei. Nur beim editieren nicht. Wie kann ich das da machen?


Danke

Share this post


Link to post
Share on other sites
Guest

Da bekommt man ja Augenkrebs. Lies unbedingt mal den Manual-Eintrag zu echo und ignoriere dabei bitte die shortcut syntax.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×