Jump to content

probleme bei der anmeldung


Recommended Posts

hallo ..


ich habe ien problem bei der Registrierung ...


ich nutze pforum 1.30

mysql 5 und php 5


wenn sich jetzt ein user Registrierung will und kein geb datum oder geschlecht angibt

bekomme ich eine fehlermeldung


beim geschlecht ist es "Data truncated for column 'gender' at row 1"

und beim geb "Incorrect date value: '--' for column 'birthday' at row 1"


kann mir da wer helfen ?

Link to post
Share on other sites

Hallo,


also du sollest deinem Hoster eins in die Fresse schlagen:

 

Client API version: 3.23.49
allow_url_fopen: On



MySQL sollte mindestens bei Version 4.1.x liegen.


Zu deinem Problem: Ich vermute, dass es mit der zu alten Datenbankversion zusammenhängt. Updaten lassen und dann nochmal schauen.



Grüße

Link to post
Share on other sites

Hallo,


gehe mal bitte in den phpMyAdmin und schicke hier rein mal die Struktur der Tabelle pfuser. Also du musst die Datenbank wo die drin ist aufrufen. Dort dann die Tabelle und oben auf Exportieren klicken. Den SQL-Kommando mit CREATE TABLE würde ich mir gern mal anschauen.


Anbei, ggf. nochmal die pforum_createdb.php ausgeführt? Und was du auch machen kannst, mal auf die 1.31 OS updaten / alternativ auch aufs pSys.



Grüße

Link to post
Share on other sites

also habe schon neues forum aufgesetzt zum testen ... geht nicht habe die 1.31 versucht ... geht auch net


CREATE TABLE `pfuser` (

`id` int(14) NOT NULL auto_increment,

`username` varchar(50) default NULL,

`pwd` varchar(50) default NULL,

`nickname` varchar(50) default NULL,

`email` varchar(100) default NULL,

`uin` varchar(32) default NULL,

`expire` int(11) default '0',

`lastlogin` int(11) default '0',

`icq` varchar(30) default NULL,

`signatur` text,

`usertyp` varchar(10) default 'user',

`logintime` int(14) default '0',

`homepage` varchar(100) default NULL,

`joined` int(14) default NULL,

`setzps` int(11) default '20',

`postcount` int(11) default '0',

`grpid` int(11) default '0',

`info1` text,

`info2` text,

`info3` text,

`usepm` int(11) default '1',

`avatar` varchar(200) default NULL,

`showemail` int(11) default '1',

`karma` int(11) default '0',

`gender` enum('männlich','weiblich') default 'männlich',

`showkarma` int(11) default '0',

`inboard` int(11) default '0',

`birthday` date default NULL,

`pmnotify` int(11) default '1',

`usertitel` varchar(30) default NULL,

`ircserver` varchar(100) default NULL,

`ircchan` varchar(30) default NULL,

`aimid` varchar(100) default NULL,

`yahooid` varchar(50) default NULL,

`msnid` varchar(100) default NULL,

`skype` varchar(50) default NULL,

`invisible` int(11) default '0',

`ip` varchar(15) default NULL,

`reload` int(11) default '1',

`lockdown` int(11) default '0',

PRIMARY KEY (`id`),

KEY `expire` (`expire`),

KEY `invisible` (`invisible`),

KEY `uin` (`uin`),

KEY `inboard` (`inboard`),

KEY `reload` (`reload`),

KEY `lastlogin` (`lastlogin`,`logintime`)

) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=264 ;



ich habe ja ne vermutung das was mit der my.ini net stimmt oder noch was in der php,ini eingestllt werden muss


habe es noch mal auf meinem eigenen "test server" versucht ... das selbe kann das was mit mysql 5 zu tun haben ??

Link to post
Share on other sites

ich musste jetzt feststellen das so eingige ander funktionen auch nicht gehen ...


bis jetzt habe ich raus gefunden : keine neuen gruppen erstellbar und umfragen sind auch nicht möglich ...


ich komme einfach nicht weiter ...


ich dnek das es mit der mysql 5 zu tun hat habe aber keinen schimmer mehr was das sein kann ...


hat irgednwer das forum auf mysql 5 und php 5 laufen ?


mfg


Konrad

Link to post
Share on other sites
  • 2 weeks later...

gut so wie ich das sehe hat keiner ahung wo hier das problem liegen könnte ..

das mit


beim geschlecht ist es "Data truncated for column 'gender' at row 1"

und beim geb "Incorrect date value: '--' for column 'birthday' at row 1"


habe ich jetzt hin bekommen ...aber der rest ..


leider kommt dann für mich powie nicht mehr in frage ... ich verabschiede mich also damit von euch ... *schnief* habe die scripte sehr gern benutzt ..


tntkonrad


ps:kennt wer nen forum was ähnlich dem von powie ist ? phpbb ist mir zu viele schnick schnak

Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...