Jump to content
powie.de Tech Forum
vinzenzfischer

pNews Probleme nach Serverwechsel

Recommended Posts

Tag zusammen,


ich hab - und das ist schon etwas her - früher mal ganz gerne Powie-Scripte genutzt.

Irgendwann hat sich meine Tätigkeit im Bereich Webhosting/"Webdesign" aber stark reduziert, heute bin ich schwerpunktmäßig in der Microsoft-Welt zu Hause, habe aber aus alten Tagen immer noch ein paar Seiten, die auf einem dedizierten Linux-Server liegen - und die auch zum Teil noch PScripte nutzen.


Nun ist mir dieser Tage einer von zwei Servern abgeraucht, Platte kaputt.

Backup war vorhanden und aktuell, und so waren die handvoll Seiten schnell auf einem anderen Server wieder online.

Leider bekomme ich nun bei einer Seite, die pNews verwendet, folgenden Fehler:

 

Content-Encoding-Fehler

Die Webseite, die Sie öffnen möchten, kann nicht angezeigt werden, da sie eine ungültige oder unbekannte Form der Kompression verwendet.

 

Die Fehlermeldung stammt aus dem aktuellen FF, im IE 10 ist die Fehlermeldung ähnlich.


Der alte Server lief mit PHP Version 5.2.6-1+lenny16, der Neue läuft mit 5.3.3-7+squeeze14.

Welche pNews-Version da aktuell läuft habe ich nicht genau eruieren können, der aktuellste Eintrag in der ChangeLog-Datei ist aber vom 7.4.2004...


Hat jemand ne Idee, wo ich den Fehler suchen muss?

Ich hätte ja gern die aktuellste Version installiert, aber der Hinweis "Du musst zum Download eingeloggt sein" und eine fehlende LogIn-Möglichkeit lassen mich vermuten, dass ein Download nicht mehr gewünscht ist...


Freue mich auf Antworten! :)



Gruß,

Vinz

Share this post


Link to post
Share on other sites

So, nach dem ich der Sache noch mal ordentlich zu Leibe gerückt bin, hab ich den "Fehler" nun ausgemacht:

 

ob_start( ob_gzhandler )

 

Dieser Eintrag steht gleich als erstes in allen config.inc.php-Dateien, die die PScripts nutzen/genutzt haben.

Habs auskommentiert, und schon geht alles wieder.


Via google habe ich recherchiert, dass hier die zlib-Bibliothek angesprochen wird. Die ist auch installiert auf dem Server.

Warums nicht tut, weiß ich nun nicht, ist aber auch erst mal egal.



Gruß,

Vinz

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×