Jump to content
Sign in to follow this  
rubberduck

pcheck

Recommended Posts

Hallo,


ich habe gerade eben versucht pcheck zu installieren, aber bin da leider auf ein kleines Problem gestoßen. :(

Also alle Daten wurden vorschriftsmässig übertragen, die Änderungen in der config.inc.php vorgenommen und pcheck_createdb.php ausgeführt. Danach habe ich mich als Admin eingeloggt und via \\\"neuer Checker\\\" einen zu überprüfenden Host eingetragen. \\\"Checker wurde erstellt\\\" und der \\\"Aktuelle Status\\\" war ok - sollte ja auch so sein. Als \\\"letzter Check\\\" wurde folgende Zeit angegeben: 01.01.1970, 01:00:00

Ich habe mich daraufhin via ssh zum Server verbunden und wollte über den betreffenden user einen cronjob anlegen. Davor wollte ich es allerdings noch manuell testen und bekam folgenden Fehler:

./sshcheck

: bad interpreter: Permission denied


Den gleichen Fehler erhalte ich wenn ich das Script via crontab ausführe (absoluter Pfad ist angegeben) und auch wenn ich die Rechte ändere.

Ich habe versucht über \\\"Aktualisieren\\\" eine Veränderung zu erwirken, aber leider auch ohne Erfolg. :(


Ich habe mir daraufhin nochmal die config.inc.php angesehen und bin auf folgendes gestoßen:

//Globale Konfiguration einlesen

@include( \\\'/home/www/web1/html/config/config.inc.php\\\');

Dies ist bei mir der falsche Pfad und ich habe den Pfad auf meine Bedürfnisse angepasst, aber leider auch wieder ohne Erfolg. :(


Ich würde mich freuen, wenn mir hierbei jemand weiterhelfen könnte. Vielen Dank im voraus.

Share this post


Link to post
Share on other sites

Ja hab ich gemacht, zur Sicherheit, siehe:

chmod +x sshcheck

./sshcheck

: bad interpreter: No such file or directory


Muss folgendes angepasst werden oder nicht:

@include( \'/home/www/web1/html/config/config.inc.php\');

Wenn ich es nämlich mache geht nichts mehr. :(

Share this post


Link to post
Share on other sites

Kann man das Script nicht auch \"alleine\", also ohne Forum betreiben?

Jedenfalls bekomm ich nen weißes Fenster bzw nen Timeout wenn ich meinen absoluten Pfad angebe


Trotz allem kann ich aber den Checker selber ja nicht ausführen, also so das er sich updated, weder \"manuell\" über den aktualisieren button, wie auch per shell oder cronjob

- Editiert von RubberDuck am 17.12.2003, 23:48 -

Share this post


Link to post
Share on other sites
Guest

Niemand ist hier verpflichtet dir Fragen zu beantworten oder dir in irgendeiner Weise Support zu geben!

Share this post


Link to post
Share on other sites

Ein kleines Stück weiter aber noch nicht erfolgreich.

Wenn ich /usr/bin/php --help aufrufe bekomme ich folgende Ausgabe:

 

> php --help
Status: 0
Content-type: text/html

PHP Warning:  Unknown(): Unable to load dynamic library \'/usr/share/extensions/no-debug-non-zts-20020429/pgsql.so\' - libpq.so.3: cannot open shared object file: No such file or directory in Unknown on line 0
Security Alert! The PHP CGI cannot be accessed directly.

This PHP CGI binary was compiled with force-cgi-redirect enabled.  This
means that a page will only be served up if the REDIRECT_STATUS CGI variable is
set, e.g. via an Apache Action directive.
For more information as to why this behaviour exists, see the manual page for CGI security.
For more information about changing this behaviour or re-enabling this webserver,
consult the installation file that came with this distribution, or visit 
the manual page.

 

Huch - hat jemand einen Rat wie ich PHP dazu bewegen kann das Script sshcheck zu verarbeiten?

Share this post


Link to post
Share on other sites

Hallo Powie,


Original von Powie

probiert das mal mit direktem aufruf:


>php sshcheck !!!



selbe Ausgabe:

 

> php sshcheck 
Status: 0
Content-type: text/html

PHP Warning:  Unknown(): Unable to load dynamic library \'/usr/share/extensions/no-debug-non-zts-20020429/pgsql.so\' - libpq.so.3: cannot open shared object file: No such file or directory in Unknown on line 0
Security Alert! The PHP CGI cannot be accessed directly.

This PHP CGI binary was compiled with force-cgi-redirect enabled.  This
means that a page will only be served up if the REDIRECT_STATUS CGI variable is
set, e.g. via an Apache Action directive.
For more information as to why this behaviour exists, see the manual page for CGI security.
For more information about changing this behaviour or re-enabling this webserver,
consult the installation file that came with this distribution, or visit 
the manual page.

 

Gruß


Olf

Share this post


Link to post
Share on other sites

also irgendwie hast du da bereits ein Problem mit PHP , und nicht mit dem Script.


mein php --help ->


david:~ # php --help

Usage: php [-q] [-h] [-s] [-v] [-i] [-f ]

php [args...]

-a Run interactively

-C Do not chdir to the script\'s directory

-c | Look for php.ini file in this directory

-n No php.ini file will be used

-d foo[=bar] Define INI entry foo with value \'bar\'

-e Generate extended information for debugger/profiler

-f Parse . Implies `-q\'

-h This help

-i PHP information

-l Syntax check only (lint)

-m Show compiled in modules

-q Quiet-mode. Suppress HTTP Header output.

-s Display colour syntax highlighted source.

-v Version number

-w Display source with stripped comments and whitespace.

-z Load Zend extension .

Share this post


Link to post
Share on other sites

Ja, ich denke auch, dass es nicht an sshcheck liegt sondern daran, dass PHP nicht direkt aufgerufen werden kann.


Das ganze allerdings auf zwei Rechnern in Standardinstallation PHP (als Modul für Apache) in SuSE 8.2. Somit denke ich, dass noch mehr User das Problem bekommen werden.


Aus meiner Sicht ist die Kernaussage der Meldung:

 

Security Alert! The PHP CGI cannot be accessed directly. 
This PHP CGI binary was compiled with force-cgi-redirect enabled.  This 
means that a page will only be served up if the REDIRECT_STATUS CGI variable is 
set, e.g. via an Apache Action directive.

 

Ich hatte die Hoffnung, dass du schonmal das Problem hattest und eine Lösung weisst. Ich muss mal nachsehen ob ich PHP anders konfigurieren kann oder ob ich ein anderes Paket brauche oder kompilieren muss.

Ansich wollte ich PHP gerne als Modul im Apache laden da ich bislang PHP auch nur da benötige.

Share this post


Link to post
Share on other sites

wenn du PHP an der Shell aufrufst hat deine Apache Sache absolut keine Auswirkung...

Das force-cgi-redirect ist ein Problem, das ist aber definitiv kein Standard. Das muss aus welchem Grund auch immer direkt beim kompilieren deiner PHP Binaries angegeben wurden sein. Ich habe bei mir mal über verschiedene Maschinen geschaut, dort ist das nirgendwo in Benutzung.

Share this post


Link to post
Share on other sites

PHP Manual:

Case 2: using --enable-force-cgi-redirect

This compile-time option prevents anyone from calling PHP directly with a url like http://my.host/cgi-bin/php/secretdir/script.php. Instead, PHP will only parse in this mode if it has gone through a web server redirect rule.


Usually the redirection in the Apache configuration is done with the following directives:


copy to clipboard

Action php-script /cgi-bin/php

AddHandler php-script .php


This option has only been tested with the Apache web server, and relies on Apache to set the non-standard CGI environment variable REDIRECT_STATUS on redirected requests. If your web server does not support any way of telling if the request is direct or redirected, you cannot use this option and you must use one of the other ways of running the CGI version documented here.



Kurz und Knapp: Kein Command Line Interface !!!

Share this post


Link to post
Share on other sites
Original von Powie

Kurz und Knapp: Kein Command Line Interface !!!



Das sieht fast so aus :-(

Das Problem ist, dass ich PHP nicht selbst compiliert habe sondern als Binary-RPM von der SuSE CD installiert habe. Ich ahb mir auch schon die Finger wund gesucht bei rpmseek.com ob es ein RPM für SuSE gibt welches auch in der Shell auszuführen ist. Bislang nichts.

Im Compilieren bin ich leider nicht der Meister :-(

Share this post


Link to post
Share on other sites

das ist absolut simpel, ich kompiliere nur selber, weil man da sicher gehen kann das es funzt :-D


Kann dir auch gern ein 4.3.4 kompilieren!

Share this post


Link to post
Share on other sites
Original von Powie

das ist absolut simpel, ich kompiliere nur selber, weil man da sicher gehen kann das es funzt :-D


Kann dir auch gern ein 4.3.4 kompilieren!



Das wäre natürlich klasse. Ich meine derzeit ist 4.3.1 auf dem Rechner.

Meinst du das funktioniert dann?

Share this post


Link to post
Share on other sites

Komisch - der qualifizierte Aufruf


/usr/bin/php /pfad/zum/Script/sshcheck


läuft einwandfrei. [Ratlos]


php sshcheck bringt den Fehler.


@Powie

besten Dank! :-)

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×